permuting several lists (was Re: [Python-Dev] zip() and list-comprehension with commas)

Guido van Rossum
Wed, 12 Jul 2000 20:38:28 -0500

> Barry A. Warsaw <>:
> > Is weave() perhaps a better name?

> I *like* it.  Better than the `with()' I independently invented.
> I think the fact that three people indeoendently invented 
> with()/parallel()/weave()/zip() in responmse to the syntax discussion
> is in itself pretty good evidence that a generator builtin would be better
> than new syntax.

Yes, I agree.  Main reason: it's trivial to combine this with list
comprehensions, while the ';' notation had real problems there.

My bid for a name: splice().

--Guido van Rossum (home page: