[Python-Dev] PEP 201 - Parallel iteration

Vladimir Marangozov Vladimir.Marangozov@inrialpes.fr
Mon, 17 Jul 2000 22:15:40 +0200 (CEST)

Barry A. Warsaw wrote:
> I've made a final pass through PEP 201, Parallel Iteration.

Nice! I think that a broader audience needs to read this.
Why not asking for reactions on c.l.py?

> High bit: Guido strongly prefers zip() as the name of the built-in.
> All the suggestions so far have pluses and minuses, and in the absence
> of a clear winner, he'd just as soon go with the Haskell name.  I
> agree.

I don't feel comfortable with it. Period.
You might want to see what http://www.dict.org has to say about it.

Looking at the examples for this builtin function, and without thinking
too much about the name, I'd call it - fold().

zip-gun'ly y'rs
       Vladimir MARANGOZOV          | Vladimir.Marangozov@inrialpes.fr
http://sirac.inrialpes.fr/~marangoz | tel:(+33-4)76615277 fax:76615252