[Python-Dev] PEP 201 - Parallel iteration

Moshe Zadka Moshe Zadka <moshez@math.huji.ac.il>
Tue, 18 Jul 2000 08:54:15 +0300 (IDT)

On Mon, 17 Jul 2000, Barry A. Warsaw wrote:

[On the builtin that resembles lambda *args: map(None, *args)]
> High bit: Guido strongly prefers zip() as the name of the built-in.
> All the suggestions so far have pluses and minuses, and in the absence
> of a clear winner, he'd just as soon go with the Haskell name.  I
> agree.
> Please see the new reference implementation, which includes a
> __len__() method, and the discussion of the rejected elaborations.
> There's still the open issue of what zip(sequence_a) should return.

I'm +1 on that. One thing that bugs me is that we're adding a builtin type.
Why not stick with the Python implementation?

Moshe Zadka <moshez@math.huji.ac.il>
There is no GOD but Python, and HTTP is its prophet.