[Python-Dev] Re: Berkeley DB

Fred L. Drake, Jr. fdrake@beopen.com
Tue, 25 Jul 2000 11:56:05 -0400 (EDT)

Eric S. Raymond writes:
 > There is already a bsddbmodule.c.  Can somebody explain why some module names
 > have a leading underscore and some don't?

  I was under the impression that db_wrap was an implementation detail
for some Python code; module names with a leading underscore are not
intended to be directly used by anything other than a Python wrapper
module.  The existing bsddb module *is* the public interface; if
db_wrap is a direct replacment, it should be called bsddb instead of


Fred L. Drake, Jr.  <fdrake at beopen.com>
BeOpen PythonLabs Team Member