[Python-Dev] Re: Cuddly constants seek loving, stable home

Greg Stein gstein@lyra.org
Thu, 23 Aug 2001 19:30:00 -0700

On Thu, Aug 23, 2001 at 10:43:37AM -0400, Guido van Rossum wrote:
> > >>>>> "KY" == Ka-Ping Yee <ping@lfw.org> writes:
> >     KY> Just a suggestion, but how about sys.consts?  Like os.path, as
> >     KY> in sys.consts.CO_NESTED, sys.consts.CO_FUTURE_DIVISION, etc.
> >     KY> So there's only one new object in sys, and it can contain the
> >     KY> weird internal stuff. :)
> +0.  It's the better solution but I bet it's more work to code it than
> _sysconst.  I'm not volunteering, and I want Tim to have time to help
> with the type/class unification, which is behind schedule.

Hmm... that sounds a lot like trading off expediency for Rightness. If it is
the better solution, then that should be done.

If you don't want Tim to work on it, then that is a different problem. It
could be done later, or a volunteer could step up to do it. It isn't exactly
a time critical change, now is it?


Greg Stein, http://www.lyra.org/