[Python-Dev] PEP 264
26 Aug 2001 14:41:39 -0400
"Tim Peters" <firstname.lastname@example.org> writes:
> [Michael Hudson]
> > I'd just like to note in passing that I considered most of the places
> > the CO_* constants ended up in the last week, and rejected them as too
> > gross. My idea was that
> > __future__.generators.compiler_flag
> > was to be the *only* (Python) name for CO_GENERATORS_ALLOWED (for
> > example). Are there problems with this (other than the fact that you
> > have to make sure two sets of magic numbers match up - but you have to
> > edit __future__.py when you add a new future feature anyway...).
> The problem is that nobody is going to *remember* the subtleties. IIRC,
> almost every bug I tracked down was due to *someone* neglecting to fiddle
> all the places that needed to be fiddled when changing future-flags. So The
> Rule I implemented was two-fold:
OK, I see. In this spirit, wouldn't it be better to define the
PyCF_MASK and PyCF_MASK_OBSOLETE flags in the same place as the CO_*
flags they're made up of?
Richard Gabriel was wrong: worse is not better, lying is better.
Languages and systems succeed in the marketplace to the extent that
their proponents lie about what they can do.
-- Tim Bradshaw, comp.lang.lisp