[Python-Dev] PEP 229 checked in

Andrew Kuchling akuchlin@mems-exchange.org
Wed, 17 Jan 2001 18:09:47 -0500

On Wed, Jan 17, 2001 at 11:49:25PM +0100, Thomas Wouters wrote:
>I have a couple of questions: what to do when setup.py doesn't work ? Is
>there a way to make it bypass a module ? What about specifying include dirs

There's a 'disabled_module_list' global in the code, but no way to set
it from the command-line yet, since I couldn't figure out how to do
that in time.

>On BSDI, readline sits in /usr/local or /usr/contrib, and isn't detected by
>setup.py. Also, SSL support for the socket module was not enabled, though
>OpenSSL is installed, in the default path.

Can you take a look at the detection code in setup.py and see what's
going wrong.  I believe it should be found if OpenSSL is in
/usr/local/, but /usr/contrib isn't checked currently.

>The Tcl/Tk header files are stored in /usr/include/tcl<ver>/ on Debian,
>which I personally like a lot, though it's probably a bitch to autodetect.
>(I tried, using autoconf ;-P)

There's code to handle Debian, though I have no way of testing it, and
it worked on Neil's Debian box for some reason.  Search for
debian_tcl_include in setup.py, and see if you can fix it.

>distutils.errors.DistutilsPlatformError: invalid Python installation: unable to open /usr/lib/python2.1/config/Makefile (No such file or directory)

Are you sure setup.py is up to date; do a 'cvs update setup.py' to check.  
You might get a "setup.py is in the way; remove it' message if you 
downloaded the first setup.py script manually.

>without 'make clean' anymore. You get a lot of undefined-symbol warnings
>(see below.) If you run 'make clean;make test' it also doesn't work, because
>the build directory is not in the Python library path, and regrtest.py
>requires (at least) the time module.

Again, be sure the tree is up to date; I think this stems from
attempting to compile the signal module as shared, which doesn't work.
I know that "make test" doesn't work, but am not sure how to fix it