[Python-Dev] PEP 229 checked in

Thomas Wouters thomas@xs4all.net
Fri, 19 Jan 2001 00:02:09 +0100

On Thu, Jan 18, 2001 at 10:30:36AM -0500, Andrew Kuchling wrote:
> >On Wed, Jan 17, 2001 at 11:49:25PM +0100, Thomas Wouters wrote:
> >> On BSDI, readline sits in /usr/local or /usr/contrib, and isn't detected by
> >> setup.py. Also, SSL support for the socket module was not enabled, though
> >> OpenSSL is installed, in the default path.

> What does the layout of /usr/contrib look like?  Is it
> /usr/contrib/openssl/include/, /usr/contrib/include/, or something
> else?

Actually, it's /usr/local, not /usr/contrib. I've never installed OpenSSL in
/usr/contrib, though I could, and maybe BSDI will, in the future. (BSDI
installs its own software in /usr, and optional free, pre-compiled software
in /usr/contrib.) OpenSSL installs into
/usr/local/ssl/include/openssl by default, and installing into /usr/contrib
would make it /usr/contrib/ssl/include/openssl.

> >Strangely enough, this problem does not exist on FreeBSD. I can run 'make'
> >or 'make test' after 'make' just fine. 'make test' still doesn't work
> >because of the incorrect library path, but it doesn't barf like the other
> >systems (BSDI and Debian Linux)

> Have you already run "make install"?  Perhaps it's picking up the
> already-installed modules when running "make test", because it really
> shouldn't be working.

Hm, I think you misread my statement. 'make test' *doesn't* work. But it
doesn't barf on the signal module being built dynamically either. You fixed
that for every platform now, I was just pointing out that this was not a
problem for FreeBSD for some reason.

'make test' still doesn't work, but I can make it work by specifying a
hand-tweaked PYTHONPATH that includes the OS/arch-dependant build directory.

This brings me to another point: how can 'make test' work at all ? Does
python always check for './Lib' (and './Modules') for modules ? If that's
specific for 'make test' and running python in the source distribution, that
sounds like a bit of a weird hack. I can't find any such hackery in the
source, but I also can't figure out how else it's working :)

More-later--Meteor-((c)-1979)-is-on-ly y'rs
Thomas Wouters <thomas@xs4all.net>

Hi! I'm a .signature virus! copy me into your .signature file to help me spread!