[Python-Dev] Corrupt Jython CVS (off topic).

Guido van Rossum guido@digicool.com
Sat, 30 Jun 2001 14:06:35 -0400

> A week ago I posted this on jython-dev, but no-one was able to give any
> advise on the best way to fix it. Maybe you can help.
> For some time now, our [jython] web CVS have not worked correctly:
> http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/jython/jython/org/python/core/
> Finally I managed to track the problem to the Java2Accessibility.py,v
> file in the CVS repository. The "rlog" command cannot be executed on
> this file. 
> >From the start of the Java2Accessibility.py,v:
> head    2.4;
> access;
> symbols
>         Release_2_1alpha1:2.4
>         Release_2_0:2.2
>         Release_2_0rc1:2.2
>         Release_2_0beta2:2.2
>         Release_2_0beta1:2.2
>         Release_2_0alpha3:2.2
>         Release_2_0alpha2:2.2
>         Release_2_0alpha1:2.2
>         Release_1_1rc1:2.2
>         Release_1_1beta4:2.2
>         Release_1_1beta3:2.2
>         2.0:;
> locks; strict;
> As an experiment, I tried to remove the strange "2.0:;" line from
> the file and then I could run rlog on the file.

Make sure to move the semicolon to the end of the previous line.

> Does anyone know if/how we can fix this?
> As a last resort I suppose I can attach my hand edited version to a SF
> support request where I ask them to copy my file to the CVS server. To
> this day I have never been very successful whenever I have tried to edit
> files in a CVS repository so I'm reluctant to do this.
> regards,
> finn

Yes, I think a SF request should be the way to go.

I don't know how this could have happened; the "2.0" is illegal as a
symbolic tag name...

--Guido van Rossum (home page: http://www.python.org/~guido/)