[Python-Dev] Re: PEP 279
Tue, 2 Apr 2002 05:25:45 -0600 (CST)
On Tue, 2 Apr 2002, Raymond Hettinger wrote:
> Now, that's a great idea. See you guys tomorrow. It's time for me to
I prefer "enumerate" to "indexer" as well, though it's a bit long.
"enum" would be nice.
(I don't really see how it would ever collide with C's meaning for
"enum" -- the current idiom for simulating enumerated types is very
different, and even if Python eventually gets a type system fancy
enough to handle types with alternatives, we won't use "enum" to
describe them -- we'll just have alternatives, and probably use "|"
or something like that.)