[Python-Dev] Re: Stability and change

Barry A. Warsaw barry@zope.com
Mon, 8 Apr 2002 17:06:40 -0400


>>>>> "SM" == Skip Montanaro <skip@pobox.com> writes:

    BAW> I'd dread having to explain to people "this is compatible
    BAW> with Python Python 2.4.2 but not anything earlier than 2.4.1
    BAW> unless you're on the 2.3.x branch and then 2.3.7 is okay, but
    BAW> not 2.3.6 or earlier."

    SM> That's just it.  You *never, never, never* require *any*
    SM> development release to run an external package.  If you
    SM> release a package that requires that sort of coupling, Guido
    SM> simply calls in a favor from one of his Italian cousins in the
    SM> Soprano or Corleone families (my apologies for the crude
    SM> American Mafia-style references, Alex), and they take care of
    SM> you. :-)

Okay, so now I tell have to tell people that it works with any version
between 2.4.3 and 2.6.9, not including any 2.5.x release.

can't-we-just-call-them-all-bruce-and-avoid-the-confusion?-ly y'rs,
-Barry