[Python-Dev] Re: PEP 279 revisited
Wed, 24 Apr 2002 17:41:03 +0200
On Wednesday 24 April 2002 05:34 pm, Patrick K. O'Brien wrote:
> I'm partial to enumerate, but agree with Alex that since it returns a type
It IS a type; calling it returns an instance of the type. (Calling any
callable returns an instance of SOME type, after all:-).
> The new type is a numerator but that is a mouthful so the built-in function
> should be named numer(), just like iter() is short for iterator. If people
Nice. I doubt it will fly, but among the alternatives mentioned so far it
gets my vote.