[Python-Dev] Re: PEP 279 revisited
David Abrahams" <firstname.lastname@example.org
Wed, 24 Apr 2002 11:13:45 -0500
----- Original Message -----
From: "Alex Martelli" <email@example.com>
> > The new type is a numerator but that is a mouthful so the built-in
> > should be named numer(), just like iter() is short for iterator. If
> Nice. I doubt it will fly, but among the alternatives mentioned so
> gets my vote.
Blick. Abbrevs suck. Plus I don't want to re-use the sucky name enum for
something related to what 'C' and C++ use it for.
+1 for itemize
+0.8 for enumerate (in other contexts/languages/systems it just returns
the items in sequence like a python iterator does). OK, so round it up
to 1 if fractions are illegal.