[Python-Dev] Re: PEP 279 revisited

Aahz aahz@pythoncraft.com
Wed, 24 Apr 2002 12:23:39 -0400

On Wed, Apr 24, 2002, Patrick K. O'Brien wrote:
> The new type is a numerator but that is a mouthful so the built-in
> function should be named numer(), just like iter() is short for
> iterator. If people can learn and remember iter(), it should be just
> as easy to learn and remember numer(). They are spelled almost the
> same, they rhyme, they are short, etc. All the logic that lead to the
> selection of iter() should apply here.

Hrm.  I'm not quite changing my vote yet, but numerator() might work; I
don't like numer() because it looks like it's missing a "b".  I'm also
rethinking whether I should cast my vote for iterindexed().
Aahz (aahz@pythoncraft.com)           <*>         http://www.pythoncraft.com/

What if there were no rhetorical questions?