[Python-Dev] Zipping Zope3

Just van Rossum just@letterror.com
Thu, 19 Dec 2002 10:17:33 +0100


Fredrik Lundh wrote:

> Just van Rossum wrote:
> 
> > We (as in: all of us) simply need more time to come up with a
> > decent, coherent and simple set of (optional) extensions to the
> > protocol.
> 
> some of us has been shipping deployment tools for many years, and
> have a pretty good understanding of what optional extensions we and
> our customers have needed over the years...

Ok, replace "all of us" by "all of us except /F".

Seriously, what do you want me to do? Guido asked for

    i.stat_file(filename)
    i.open_file(filename)

you asked for

    i.get_module_names()
    i.load_data()

Jack asked for

    i.get_module_code(modulename)
    i.get_module_source(modulename)

I'm sure someone suggested i.listdir() or else someone will.

Although I agree with the intentions of all of those suggestions,
there's just no way we can please everyone right now.

Btw. what you want is _possible_ with the  current zipimporter object:
there's zi.get_data(filename), and you can inspect the "files" attribute
(a dict mapping filenames to index info; it's an internal attribute, so
I might rename it to _files).

I have enough on my hands to get the PEP done and to get the
implementation and the basic design right. Design descisions about
(optional) extensions to the importer protocol will have to wait. If
someone wants to pick that up and make a concrete proposal, be my guest.

Just