[Python-Dev] Write All New Import Hooks (PEP 302) in Python, Not C

Michael Hudson mwh@python.net
28 Dec 2002 17:52:43 +0000


Just van Rossum <just@letterror.com> writes:

> Michael Hudson wrote:
> 
> > I've not really been following this discussion with utmost care, but
> > the name "meta_path" doesn't move me.  Wouldn't sys.importers be
> > better name?  Or maybe I'm misunderstanding it's intent -- which is
> > still an argument for a better name.
> 
> I don't like the name much either, but it _does_ fit quite well as the
> idea is that sys.path importing gets invoked through an item on
> meta_path. Perhaps this sketch helps a little:
> 
> 
> sys.meta_path = [
>     BuiltinImporter(),  # handles builtin modules
>     FrozenImporter(),   # handles frozen modules
>     PathImporter(),     # handles sys.path
> ]
[...]

Right, that's what I thought was roughly the plan -- but I still don't
like the name.  In this world, sys.path is sort-of subsidiary to
sys.meta_path -- which jars, to me at least.  It makes sense with a
bit of historical knowledge, but not without, IMHO.

Of course, these mild gripes shouldn't delay the real work -- but
names are important.

Cheers,
M.

-- 
  Remember - if all you have is an axe, every problem looks 
  like hours of fun.                                        -- Frossie
               -- http://home.xnet.com/~raven/Sysadmin/ASR.Quotes.html