[Python-Dev] PEP 292, Simpler String Substitutions

Aahz aahz@pythoncraft.com
Thu, 20 Jun 2002 12:43:23 -0400

I'm about a pure 0 on this proposal in the aggregate

I'm -1 on .sub() as the name; I'd rather it be called .interp() (this
mainly due to confusing with the existing re.sub() and str.replace())

I'm +0 on putting this functionality in the text module instead of
adding a string method

I'm +0 on trying to find a solution that uses % instead of $ (There's
Only One Way)

I'm -1 on ${name}; there's no reason not to at least use $(name) for
Aahz (aahz@pythoncraft.com)           <*>         http://www.pythoncraft.com/

Project Vote Smart: http://www.vote-smart.org/