Guido van Rossum
Wed, 01 May 2002 09:16:08 -0400
> > I'd much rather see a patch that just changed zip() to be an iterator
> > instead of adding an iterzip().
> Wouldn't it be better as a lazy sequence a la xrange()
> that produces an iterator, rather than being an
> iterator itself?
No, lazy sequences are a thing from the past, trying to do what
iterators are for. (And yes, I know that a lazy sequence has
--Guido van Rossum (home page: http://www.python.org/~guido/)