[Python-Dev] to string or not to string...
Fri, 24 May 2002 14:22:54 -0700
Guido van Rossum wrote:
>'str' and 'string' have to be separate because the whole point is that
>isinstance(u"", string) returns True.
I understand that. I was just expressing that the names are awfully
semantically close for the newbie.
>We could rename string to basestring?
That'd be better, IMO -- or even "strings", "anystring" or
>>Do we want string to be both the module and the interface
>>masquerading as a type?
>That would *almost* work (string.lower could be an unbound method that
>calls the corresponding real class method) except string.join() would
>have the arguments reversed. :-(
>>[Trent gets the credit for asking the question -- I'm just the tester =)]
>Trent needn't be so shy. :-)
Trent wasn't shy, he was just too lazy to update and rebuild to test,
while I have paperwork to do so anything is more interesting.