[Python-Dev] deprecating string module?
Wed, 29 May 2002 14:17:39 +0200
Skip Montanaro wrote:
> It has nothing to do with 11k worth of disk space and everything to do with
> "there's one (best) way to do it".
String method's are really nice! (By the way: I miss a length() method)
But in some cases the old-school string module yields the more readable code.
So the "one (best) way" is not always the clearest to read and understand.
I cannot see/understand why it's the "best" way to write for example
fromaddr = " ".join(map(lambda x: x ,
with this (IMHO not intuitive empty string " ") instead of
fromaddr = string.join(map(lambda x: x ,
It's much cleaner to read and understand with string instead of " " - at least
for beginners, or?