[Python-Dev] Re: [getopt-sig] Adding Optik to the standard library

Guido van Rossum guido@python.org
Thu, 30 May 2002 12:27:38 -0400

I think it's better to pick a new name and leave the existing getopt
module alone.

I think keeping it a package is fine.  I prefer to have little or no
magic in __init__.py though (the email package's __init__.py is
borderline :-).

I think that "options" is a fine package name.  Yes, there are other
things that one could consider options.  No, I don't think that will
cause confusion.  After all "getopt" isn't much more specific. :-)

--Guido van Rossum (home page: http://www.python.org/~guido/)