[Python-Dev] String module

Guido van Rossum guido@python.org
Thu, 30 May 2002 16:10:49 -0400


> > Someone commented that isxdigit is a poor name.  OTOH it's what C
> > uses.  I'm not sure what to say.
> 
> I concur.  I had to look it up on google to make sure in meant
> what I surmised it meant.  ishexdigit() is more explicit.
> Besides, C naming conventions aren't exactly role models for clarity ;)
> 
> While we're at it:
>  isgraph() --> isvisible()
>  iscntrl() --> iscontrol()
>  isprint() --> isprintable()

Sure.  But I still can't guess the relationships between these three
graph excludes space, print includes it).

And then maybe also ispunctuation()?  Or is that too long?

My ctype.h man page also has these:

isblank -- space or tab (GNU extension)
isascii -- 7-bit value (BSD/SVID extension)

--Guido van Rossum (home page: http://www.python.org/~guido/)