[Python-Dev] Currently baking idea for dict.sequpdate(iterable, value=True)

Guido van Rossum guido@python.org
Tue, 26 Nov 2002 11:41:06 -0500

> And maybe the method should be named fromkeyseq, because there
> is another constructor that creates the dict from a sequence
> of items.


> (Maybe this constructor should be made into a
> class method fromitemseq?)

Too late -- it's already dict() in Python 2.2.

--Guido van Rossum (home page: http://www.python.org/~guido/)