[Python-Dev] Re: os.path.walk() lacks 'depth first' option

Jeremy Fincher fincher.8@osu.edu
Fri, 25 Apr 2003 19:48:26 -0400

On Thursday 24 April 2003 12:50 pm, Guido van Rossum wrote:
> Agreed.  How about naming it os.walk()?  I think it's not OS specific
> -- all the OS specific stuff is part of os.path.  So we only need one
> implementation.

It's a minor quibble to be sure, but os.walk doesn't really describe what 
exactly it's doing.  I'd suggest os.pathwalk, but that'd be too error-prone, 
being os.path.walk without a dot.  Perhaps os.pathwalker?

Just a (likely ill-informed :)) opinion :)