[Python-Dev] Re: "groupby" iterator
pf_moore at yahoo.co.uk
Wed Dec 3 13:33:35 EST 2003
Jeremy Fincher <fincher.8 at osu.edu> writes:
> On Tuesday 02 December 2003 11:02 am, Paul Moore wrote:
>> Alex Martelli <aleaxit at yahoo.com> writes:
>> > Since these functions or types are going to be in operator, I think
>> > we can afford to "spend" two names to distinguish functionality
>> > (even though attgetter and itemgetter look nowhere as neat as
>> > extract -- I don't have better suggestions offhand).
>> operator.getattr and operator.getitem?
> I think the functions they're talking about are actually right-curried
> versions of those functions, like this:
I know - I was hoping that the fact that these particular versions
were in the operator module might justify using the same name for two
But it's probably more confusing than helpful.
This signature intentionally left blank
More information about the Python-Dev