[Python-Dev] Why did Fredrik leave the party?

Eric S. Raymond esr@thyrsus.com
Wed, 5 Feb 2003 13:43:51 -0500


Guido van Rossum <guido@python.org>:
>     synchronized(lock):
>         BLOCK
> 
> instead of
> 
>     lock.aqcuire()
>     try:
>         BLOCK
>     finally:
>         lock.release()
> 
> I assure you that this makes programs that use locks more readable,
> which reduces maintenance costs down the road.  But at the same time
> we can't hope to reduce every idiom to a single statement, and we must
> be careful not to destroy the language by adding too many "neat
> tricks".

I'm going to have to come out against this idea.  I think it violates
"explicit is better than implicit", and is perilously close to being
mere syntactic sugar.
-- 
		<a href="http://www.catb.org/~esr/">Eric S. Raymond</a>