[Python-Dev] cygwin errors

Jason Tishler jason@tishler.net
Fri, 18 Jul 2003 12:44:23 -0400


On Fri, Jul 18, 2003 at 11:21:38AM -0500, Skip Montanaro wrote:
> I made a little progress narrowing down the cygwin errors.

Unfortunately, not.

> If I simply run
>     ./python.exe Lib/test/regrtest.py
> the first test which fails is test_bz2.  If I run test_bz2 by itself
> it succeeds.  I created a shell script which just executed pairs of
> tests, one of the ones which was run before test_bz2 followed by
> test_bz2.  A couple tests caused test_bz2 to fail:
>     test___all__
>     test_asynchat
> Here's the error output:
>     C:\cygwin\home\Administrator\src\python\dist\src\python.exe: ***
>     unable to remap C:\cygwin\bin\cygssl-0.9.7.dll to same address as
>     parent(0x11B0000) != 0x11C0000

The above is due to the dreaded Cygwin fork() problem that requires you
to rebase your DLLs.  The following are the relevant snippets from the
Cygwin Python README:

    As of Cygwin Python 2.2.2-3, it is assumed that your Cygwin system
    has been rebased in order to prevent fork() failures due to DLL base
    address conflicts.  Previous versions worked around this issue by
    building the _socket module statically.  This hack no longer works
    with current Cygwin versions.  See the issues section for more

    3. Due to issues with Cygwin's fork() and DLL base address
    conflicts, one should rebase their Cygwin system to prevent fork()
    failures.  Use the following procedure to rebase your system:

        a. install the Cygwin rebase package (if necessary)
        b. shutdown all Cygwin processes
        c. start bash (do not use rxvt)
        d. execute rebaseall (in the bash window)

I was going to mention rebasing in a previous post but I didn't see the
telltale "remap" error message.  Sorry...


PGP/GPG Key: http://www.tishler.net/jason/pubkey.asc or key servers
Fingerprint: 7A73 1405 7F2B E669 C19D  8784 1AFD E4CC ECF4 8EF6