[Python-Dev] Where to put the interrupt module?

Kurt B. Kaiser kbk@shore.net
Fri, 13 Jun 2003 15:36:51 -0400


Guido van Rossum <guido@python.org> writes:

>> > Hm, that's not bad.  It should be called sys.interrupt_main() then.
>> 
>> Works for me!
>> 
>> http://sourceforge.net/tracker/index.php?func=detail&aid=753733&group_id=5470&atid=305470
>
> Hm, but since this only makes sense if you have threads, shouldn't it
> be in the thread extension module?  Also, you forgot the patch to
> idlelib/run.py. :-)

Oh, I did that when I tested sys.interrupt_main()  :-)

But not checked in until I saw whether the patch would stick.

> If this makes sense to you, just check it in.

It sounds to me like thread.interrupt_main() is the way to go for now.

That naming makes the limitation evident.  If there should be a
subsequent generalization to the implementation, it's no problem to
update IDLE's run.py if thread.interrupt_main() gets deprecated.

I'll post a revision to the patch.

__
KBK