[Python-Dev] Re: [Python-checkins] python/dist/src/Modules _hotshot.c,1.32,1.33 arraymodule.c,2.84,2.85 xreadlinesmodule.c,1.13,1.14
Mon, 17 Mar 2003 11:57:56 +0100
On Mon, Mar 17, 2003 at 12:35:54AM -0800, firstname.lastname@example.org wrote:
> Created PyObject_GenericGetIter().
> Factors out the common case of returning self.
PyObject_GenericGetIter doesn't really describe what it does; I would assume
that tried to get the iter by assuming obj was a sequency type, and
returning an iter that wraps that. Wouldn't "PyObject_GetSelfIter" or
"PyObject_GenericSelfIter" or "PyObject_SelfIter" be a better name ?
Thomas Wouters <email@example.com>
Hi! I'm a .signature virus! copy me into your .signature file to help me spread!