[Python-Dev] which sleepycat versions do we support in 2.3.* ?

Alex Martelli aleaxit at yahoo.com
Wed Nov 12 08:07:48 EST 2003

On Wednesday 12 November 2003 01:45 pm, Barry Warsaw wrote:
> On Wed, 2003-11-12 at 03:14, Alex Martelli wrote:
> > I believe that setup.py is accurate, README slightly out of date,
> > Modules/Setup way out of date -- but I thought that double
> > checking couldn't possibly hurt.  So, can I confirm this to the
> > help at python.org querant, and fix the comments in README (should
> > it say 3.1 through 4.2, or 3.2 through 4.2, given the "only partial
> > support" for 3.1?) and Modules/Setup (presumably with a pointer to
> > setup.py)?
> Greg can give the definitive answer here, but my understanding is that
> the bsddb wrapper in Python 2.3 probably requires at least BerkeleyDB
> 3.3.11, supports up to 4.1.25, with the latter recommended (if it were
> up to me, at least :).  The wrapper in Python 2.3.x probably does not
> support BerkeleyDB 4.2.x.

Hmmm -- that's bad, because 2.3's setup.py does appear to be looking
for 4.2 with priority, so, if that's installed on the user's machine, we might
be looking for trouble...


More information about the Python-Dev mailing list