[Python-Dev] which sleepycat versions do we support in 2.3.* ?

Gregory P. Smith greg at electricrain.com
Thu Nov 13 03:30:48 EST 2003

On Wed, Nov 12, 2003 at 07:45:00AM -0500, Barry Warsaw wrote:
> On Wed, 2003-11-12 at 03:14, Alex Martelli wrote:
> > I believe that setup.py is accurate, README slightly out of date,
> > Modules/Setup way out of date -- but I thought that double
> > checking couldn't possibly hurt.  So, can I confirm this to the
> > help at python.org querant, and fix the comments in README (should
> > it say 3.1 through 4.2, or 3.2 through 4.2, given the "only partial support"
> > for 3.1?) and Modules/Setup (presumably with a pointer to setup.py)?
> Greg can give the definitive answer here, but my understanding is that
> the bsddb wrapper in Python 2.3 probably requires at least BerkeleyDB
> 3.3.11, supports up to 4.1.25, with the latter recommended (if it were
> up to me, at least :).  The wrapper in Python 2.3.x probably does not
> support BerkeleyDB 4.2.x.
> -Barry

3.2 - 4.2 should work.  3.1 is too old and not worth the effort to get
to work properly again if its even possible.  I just removed checks
and mention of support for it in 2.4cvs.

I added the support for compiling with 4.2.x before 2.3.2 was released.
sleepycat gave me a beta 4.2; with luck they'll actually release it for
real soon.

The python 2.3.3 windows binary distribution should be compiled using
4.1.25 to maintain perfect compatibility with python 2.3-2.3.2.


More information about the Python-Dev mailing list