skip at pobox.com
Mon Oct 13 17:22:59 EDT 2003
>> def sort(self, cmpfunc=None, decorator=None):
Paul> I like it! But "decorator" isn't a good name - it describes how
Paul> it's being done, rather than what is being done. How about "key"?
How about keyfunc? "keyfunc=str.lower" reads to me more like "generate sort
keys using str.lower". "key" doesn't suggest (to me, at least) its value
should be a function.
More information about the Python-Dev