[Python-Dev] Re: Python-Dev Digest, Vol 3, Issue 25

Guido van Rossum guido at python.org
Mon Oct 13 18:04:28 EDT 2003


> I like "sort" better than "decorator"; I would also like "by", as in
> sort(names, by=ages.__getitem__).
> 
> I would also advocate an optional reverse=False argument, so that
> 
> result = sort(names, reverse=True)
> 
> is equivalent to
> 
> result = sort(names)
> result.reverse()

While we're at it, +1.

--Guido van Rossum (home page: http://www.python.org/~guido/)



More information about the Python-Dev mailing list