Guido van Rossum
guido at python.org
Mon Oct 13 18:05:32 EDT 2003
> Paul> I like it! But "decorator" isn't a good name - it describes how
> Paul> it's being done, rather than what is being done. How about "key"?
> How about keyfunc? "keyfunc=str.lower" reads to me more like "generate sort
> keys using str.lower". "key" doesn't suggest (to me, at least) its value
> should be a function.
But remember that a parameter name doesn't need to be documentation.
It just needs to be a memory-jogger. I think key is fine.
--Guido van Rossum (home page: http://www.python.org/~guido/)
More information about the Python-Dev