[Python-Dev] Re: Python-Dev Digest, Vol 3, Issue 25
fincher.8 at osu.edu
Mon Oct 13 19:59:44 EDT 2003
On Monday 13 October 2003 05:17 pm, Peter Norvig wrote:
> I like "sort" better than "decorator"; I would also like "by", as in
> sort(names, by=ages.__getitem__).
Coincidentally, my own decorate-sort-undecorate function is named "sortBy" :)
So I'm +1 on naming the argument "by".
> I would also advocate an optional reverse=False argument, so that
> result = sort(names, reverse=True)
> is equivalent to
> result = sort(names)
I like it.
More information about the Python-Dev