[Python-Dev] file() or open()?
paul at prescod.net
Wed Jul 7 17:14:23 CEST 2004
Guido van Rossum wrote:
> I recently saw a checkin that changed a call to open() into a call to
> file(), suggesting that using file() is more "politically correct"
> than open().
> I'm not sure I agree with this. While open() and file() are currently
> aliases for the same object, this may not always be the case (it
> certainly wasn't always the case :-).
I presumed file() was preferred to open() for the simple reason that it
says more explicitly what you are doing. You are constructing a file
object. "open()" doesn't say whether you are opening a file or socket or
window or folder or ...
open made sense in a Unix world where "everything was a file" (except
that even then it wasn't really) but it is a poor name for the file
opening function in a 21st century language.
More information about the Python-Dev