"Michael Hudson" <mwh at python.net> wrote in message news:2macl7xxpa.fsf at starship.python.net... > > Guard? Monitor? Don't really like either of these. > I know I am late, but since guard means something else, 'sentinel' (in the line of __enter__ and __exit__ interpretation) could be an alternative. Tongue in cheek.