[Python-Dev] [Python-checkins] python/dist/src/Modules _hashopenssl.c, NONE, 2.1 sha256module.c, NONE, 2.1 sha512module.c, NONE, 2.1 md5module.c, 2.35, 2.36 shamodule.c, 2.22, 2.23

Michael Hudson mwh at python.net
Tue Aug 23 16:31:55 CEST 2005

"Raymond Hettinger" <raymond.hettinger at verizon.net> writes:

> This patch should be reverted or fixed so that the Py2.5 build works
> again.
> It contains a disasterous search and replace error that prevents it from
> compiling.  Hence, it couldn't have passed the test suite before being
> checked in.  

It works for me, on OS X.  Passes the test suite, even.  I presume
you're on Windows of some kind?

> Also, all of the project and config files need to be updated for the new
> modules.

Well, yes.  But if Greg is on some unix-a-like, he can only update the
unix build files (which he has done; it's in setup.py).


 <cube> If you are anal, and you love to be right all the time, C++
   gives you a multitude of mostly untimportant details to fret about
   so you can feel good about yourself for getting them "right", 
   while missing the big picture entirely       -- from Twisted.Quotes

More information about the Python-Dev mailing list