[Python-Dev] partition() (was: Remove str.find in 3.0?)

Aahz aahz at pythoncraft.com
Tue Aug 30 06:50:05 CEST 2005

On Tue, Aug 30, 2005, Delaney, Timothy (Tim) wrote:
> Looks like I'm getting seriously outvoted here ... Still, as I said I
> don't think the name is overly important until the idea has been
> accepted anyway. How long did we go with people in favour of "resource
> manager" until "context manager" came up?

In that case, though, it was more, "Well, I'm not that happy with
'context manager', but there doesn't seem to be anything better."  This
time, it's closer to, "That's a good name for the concept, yup."  As you
say, if someone comes up with a clearly better name, it likely will win;
however, partition has been blessed by enough people that it's not worth
putting much effort into finding anything better.

> Of course, if I (or someone else) can't come up with an obviously
> better name, partition() will win by default. I don't think it's a
> *bad* name - just don't think it's a particularly *obvious* name.

It's at least as obvious as translate().  <shrug>
Aahz (aahz at pythoncraft.com)           <*>         http://www.pythoncraft.com/

The way to build large Python applications is to componentize and
loosely-couple the hell out of everything.

More information about the Python-Dev mailing list