[Python-Dev] partition() (was: Remove str.find in 3.0?)

Nick Coghlan ncoghlan at gmail.com
Tue Aug 30 15:20:03 CEST 2005

Nick Coghlan wrote:
> Another option would be simply "str.part()" and "str.rpart()". Then you could 
> think of it as an abbreviation of either 'partition' or 'parts' depending on 
> your inclination.

I momentarily forgot that "part" is also a verb in its own right, with the
right meaning, too (think "parting your hair" and "parting the Red Sea").

So call it +1 for str.part and str.rpart, and +0 for str.partition and


Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia

More information about the Python-Dev mailing list