[Python-Dev] partition() (was: Remove str.find in 3.0?)

Greg Ewing greg.ewing at canterbury.ac.nz
Wed Aug 31 03:43:59 CEST 2005

Nick Coghlan wrote:

> Another option would be simply "str.part()" and "str.rpart()". Then you could 
> think of it as an abbreviation of either 'partition' or 'parts' depending on 
> your inclination.

Or simply as the verb 'part', which also makes sense!

Also it's short and snappy, whereas 'partition' seems
rather too long-winded for such a useful little function.

Greg Ewing, Computer Science Dept, +--------------------------------------+
University of Canterbury,	   | A citizen of NewZealandCorp, a	  |
Christchurch, New Zealand	   | wholly-owned subsidiary of USA Inc.  |
greg.ewing at canterbury.ac.nz	   +--------------------------------------+

More information about the Python-Dev mailing list