[Python-Dev] PEP 8 updates/clarifications

Ian Bicking ianb at colorstudy.com
Thu Dec 15 03:09:37 CET 2005


Dave Cole wrote:
> Barry Warsaw wrote:
> 
>>I've pushed out a revised PEP 8
>>
>>http://www.python.org/peps/pep-0008.html
>>
>>Please review and comment.  Thanks everyone for providing an excellent
>>discussion.  Hopefully I have captured our current collective
>>recommendations.  I've also tried to simplify the text, while making it
>>(somewhat) more prescriptive.
> 
> 
> The only thing I strongly disagree with is the promotion of javaNaming
> to equal footing with python_naming.  We can look forward to future
> programs that look like this:

I don't see this suggestion...?  Here's what seems to be the current 
text on the matter:

     Function Names

       Function names should be lowercase, with words separated by 
underscores
       as necessary to improve readability.

       mixedCase is allowed only in contexts where that's already the
       prevailing style (e.g. threading.py), to retain backwards 
compatibility.

     Method Names and Instance Variables

       Use the function naming rules: lowercase with words separated by
       underscores as necessary to improve readability.

I know Guido in a later thread seems to be going back on that, which 
would be disappointing to me.  I think it's reasonable to loosen the 
phrasing a bit -- it's nearly always better to stay consistent with a 
package than follow PEP 8 on this point.  The current text merely 
implies that it's acceptable to follow previous convention, not preferable.

Many people who come to Python *want* to follow whatever the prevalent 
and preferred style is, but it's not immediately clear what that is.  So 
I think PEP 8 should as often as possible at least indicate preference. 
  Which it pretty much does now, so we should leave well enough alone ;)


-- 
Ian Bicking  |  ianb at colorstudy.com  |  http://blog.ianbicking.org


More information about the Python-Dev mailing list