[Python-Dev] New PyPI broken package editing

Walter Dörwald walter at livinglogic.de
Tue Mar 22 22:40:50 CET 2005

> Zitat von Walter Dörwald <walter at livinglogic.de>:
>> I've uploaded a new package to the new PyPI. Editing this
>> new packages gives me a unicode error. The URL is
>> http://www.python.org/pypi?:action=submit_form&name=ll-ansistyle&version=0.6.1
> I see that the package is online now, so I assume that
> it now worked?

Uploading worked, but editing the package afterwards fails.

>> I've used the distutils from current CVS and have
>>     author=u"Walter Dörwald"
>> in my setup.py
> This isn't supposed to work yet. Are you using the
> register command on this? Can you tell where it decides
> to encode as Latin-1? PyPI will reject anything that is
> not UTF-8.

You might be right. I've tried with author=u"..." and author=u"...".encode("utf-8"). The second version might have been the one
that worked.
> As for the uploads: you'll have noticed that it put the
> sdist files into packages/2.5; this is not supposed to
> happen. If you delete the files, and reupload them with
> the current CVS, the files should go into /packages/source.

OK, I'll try again tomorrow morning.

   Walter Dörwald

More information about the Python-Dev mailing list