[Python-Dev] Keyword for block statements
Guido van Rossum
gvanrossum at gmail.com
Mon May 2 02:25:47 CEST 2005
> Would 'suite' work as the keyword?
> Calling these things 'suite' statements would match the Python grammar,
Actually that's an argument *against* -- too confusing to have two
things we call suite.
> give an
> obvious visual indicator through the use of a keyword, reduce any confusion
> resulting from the differences between Python suites and Ruby blocks (since the
> names would now be different),
There's no need for that; they are close enough most of the time any way.
> and avoid confusion due to the multiple meanings
> of the word 'block'.
Actually, in Python that's always called a suite, not a block. (Though
the reference manual defines "code block" as a compilation unit.)
> And really, what PEP 340 creates is the ability to have user-defined suites to
> complement the standard control structures.
Give that suite and block are so close in "intuitive" meaning, if
there were no convincing argument for either, I still like "block"
much better -- perhaps because suite is the technical term used all
over the grammar.
--Guido van Rossum (home page: http://www.python.org/~guido/)
More information about the Python-Dev