[Python-Dev] Defining properties - a use case for class decorators?

Nick Coghlan ncoghlan at gmail.com
Wed Oct 19 11:25:05 CEST 2005


Josiah Carlson wrote:
>> Another option would be to allow attribute reference targets when binding 
>> function names:
> 
> *shivers at the proposal*  That's scary.  It took me a few minutes just
> to figure out what the heck that was supposed to do.

Yeah, I think it's a concept with many, many more downsides than upsides. A 
"given" or "where" clause based solution would be far easier to read:

   x.get = f given:
       def f(): pass

A given clause has its own problems though (the out-of-order execution it 
involves being the one which seems to raise the most hackles).

Cheers,
Nick.

-- 
Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia
---------------------------------------------------------------
             http://boredomandlaziness.blogspot.com


More information about the Python-Dev mailing list