[Python-Dev] Compatibility between Python 2.3.x and Python 2.4.x

Fredrik Lundh fredrik at pythonware.com
Thu Sep 15 23:36:42 CEST 2005

Rich Burridge wrote:

> I'm involved with the team that's working towards installing Python 2.4.x
> as part of a future release of the Solaris O/S.
> We currently have Python 2.3.x installed. We are trying to determine just
> how compatible these two release are (at both the binary and source levels).
> In other words, with Python 2.3.x .py, .pyc and .pyo files work correctly
> with Python 2.4.x ?

no.  most PY files may work (see the changes documents for things
that have changed


More information about the Python-Dev mailing list