[Python-Dev] Alternative name for str.partition()

Terry Reedy tjreedy at udel.edu
Wed Sep 21 22:15:14 CEST 2005

"Christian Stork" <python-dev-list at cstork.org> 
wrote in message news:20050921185601.GA22265 at anthony.ics.uci.edu...
> On Tue, Aug 30, 2005 at 12:49:26PM +1200, Greg Ewing wrote:
>> A more descriptive name than 'partition' would be 'split_at'.
> 'split_at' is really what's happening.  (I came up with it independently
> of Greg, if that is any evidence).

At least semi-seriously, how about condensing 'split_at' to 'splat', a 
variant of split (and splash), as in 'hit the string on the separator, and 
with a splat, split it into 3 pieces'.  (See dictionary.com for various 

Terry J. Reedy

More information about the Python-Dev mailing list