[Python-Dev] _length_cue()

Greg Ewing greg.ewing at canterbury.ac.nz
Thu Feb 9 03:13:25 CET 2006

Raymond Hettinger wrote:
> [Andrew Koenig]
>>Might I suggest that at least you consider using "hint" instead of "cue"?
> Personally, I prefer "cue" which my dictionary defines as "a signal, hint, 
> or suggestion". The alternate definition of "a prompt for some action" 
> applies equally well.

No, it doesn't, because it's in the wrong direction. The
caller isn't prompting the callee to perform an action,
it's asking for some information.

I agree that "hint" is a more precise name.

Greg Ewing, Computer Science Dept, +--------------------------------------+
University of Canterbury,	   | Carpe post meridiam!          	  |
Christchurch, New Zealand	   | (I'm not a morning person.)          |
greg.ewing at canterbury.ac.nz	   +--------------------------------------+

More information about the Python-Dev mailing list