[Python-Dev] defaultdict and on_missing()

Michael Chermside mcherm at mcherm.com
Wed Feb 22 22:13:28 CET 2006

A minor related point about on_missing():

Haven't we learned from regrets over the .next() method of iterators
that all "magically" invoked methods should be named using the __xxx__
pattern? Shouldn't it be named __on_missing__() instead?

-- Michael Chermside

More information about the Python-Dev mailing list