[Python-Dev] defaultdict and on_missing()

Raymond Hettinger python at rcn.com
Fri Feb 24 16:59:27 CET 2006

> Michael Chermside wrote:
>> The next() method of iterators was an interesting
>> object lesson. ... Since it was sometimes invoked by name
>> and sometimes by special mechanism, the choice was to use the
>> unadorned name, but later experience showed that it would have been
>> better the other way.

> Any thoughts about fixing this in 3.0?

IMO, it isn't broken. It was an intentional divergence from naming conventions. 
The reasons for the divergence haven't changed.  Code that uses next() is more 
understandable, friendly, and readable without the walls of underscores.


More information about the Python-Dev mailing list